Get in touch
Back
Maintenance

Prod Deployment

Completed 27 Feb at 06:00pm PST.

Updated

We are excited to announce the latest version of our Python client, v0.4.0, which simplifies the process of submitting a profile job or a validation job. The input_shapes and inputs can now be defined using a dictionary only.

For instance, to submit a profile job, you can use the following code:

job = hub.submitprofilejob(
model=...,
device=...,
input_shapes=dict(x=(3, 5)),
)

On the other hand, to submit a validation job, the inputs should be a dictionary where the values are lists of NumPy arrays. You can use the following sample code:

sample = np.random.random((1, 224, 224, 3)).astype(np.float32)
job = hub.submitvalidationjob(
model=...,
device=...,
inputs=dict(input_1=[sample]),
)

For more detailed information, please visit our documentation page at https://hub.tetra.ai/docs.

Posted 1 Mar at 10:39am PST.
Completed

Maintenance completed

Posted 27 Feb at 06:00pm PST.
Started

We are deploying a new server version

Posted 27 Feb at 04:00pm PST.